2017-02-23 25 views
0

Я действительно новичок в webpack, реагирую, babel и т. Д. У меня это работало в одно время, но я что-то прикрутил, и теперь я не могу его исправить. Я пытался заставить это работать уже несколько дней. Единственное руководство, которое я смог найти, говорит об обновлении npm и узла, и это руководство было два года. Кроме того, у меня есть последние версии обоих.Невозможно установить postcss-loader

Может кто-нибудь сказать мне, что я могу делать неправильно, или еще лучше, как не использовать postcss? Может быть, библиотека, которая делает то же самое? Возможно, список всего, что мне нужно для установки и в правильном порядке?

$ npm install postcss-loader --save-dev 
npm ERR! Windows_NT 10.0.14393 
npm ERR! argv "C:\\Program Files (x86)\\nodejs\\node.exe" "C:\\Program Files 
(x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "postcss-loader" 
    "--save-dev" 
npm ERR! node v6.9.5 
npm ERR! npm v3.10.10 
npm ERR! code ETARGET 

npm ERR! notarget No compatible version found: [email protected]^3.2.0 
npm ERR! notarget Valid install targets: 

npm ERR! notarget 1.3.1, 1.3.0, 1.2.2, 1.2.1, 1.2.0, 1.1.1, 1.1.0, 1.0.0, 
0.13.0, 0.12.0, 0.11.1, 0.11.0, 0.10.1, 0.10.0, 0.9.1, 0.9.0, 0.8.2, 0.8.1, 
0.8.0, 0.7.0, 0.6.0, 0.5.1, 0.5.0, 0.4.4, 0.4.3, 0.4.2, 0.4.1, 0.4.0, 0.3.0, 
0.2.0, 0.1.0 
npm ERR! notarget 
npm ERR! notarget This is most likely not a problem with npm itself. 
npm ERR! notarget In most cases you or one of your dependencies are requesting 
npm ERR! notarget a package version that doesn't exist. 

PS. Будучи разработчиком MS в сфере карьеры, я очень уважаю тех из вас, кто может быть продуктивным в этом стеке. Я не знаю, как вы так живете. :)

+0

Когда вы переустановили npm, вы установили его по всему миру? например, «npm install npm -g» –

+0

Да, npm, webpack и webpack-dev-сервер - это единственные вещи, которые я установил во всем мире. Это проблема? –

+0

Нет, это не проблема. Я просто хотел убедиться, что вы обновляете его по всему миру. Можете ли вы запустить 'npm --version', чтобы проверить его обновление. –

ответ

0

Чтобы решить вашу проблему. Я думаю, вам просто нужно отредактировать файл package.json и указать приемлемую версию postcss-loader. Я бы предложил использовать последнее из 1.3.1. Поэтому в вашем пакете.json укажите версию следующим образом:

"devDependencies": { 
    "postcss": "^5.2.10", 
    "postcss-loader": "^1.3.1" 
    }, 

Затем попробуйте запустить установку еще раз и посмотреть, что произойдет.

npm install postcss-loader --save-dev 
+0

Это привело меня к непосредственной проблеме, но, похоже, вызывает проблемы совместимости в другом месте. Некоторое время мне придется крутить колеса по новым проблемам. –